Jump to content
  • Sign Up
Wonko

Farming Simulator 17 Update 1.5.1 live

Recommended Posts

Farming Simulator 17 Update 1.5.1 live
Patch 1.5.1 for Farming Simulato 17 is now available for download.
This patch will also be required to install the Farming Simulator 17 – Platinum Add-On. We recommend that you update your game before its release on NOV 17.
Console & Steam players can download the patch through their platform’s system. The download for other digital and PC retail versions can be found here: https://farming-simulator.com/updat...
The complete changelog incl. previous updates can also be found on here: https://farming-simulator.com/chang...

Changes

  • [FIXED] Game freezes due third party radio streams (1.5.1)
  • [FIXED] Game crashes using tipAnything near map borders (1.5.1)
  • [FIXED] 4real module 1; usage of narrowWheels in missions and other fixes (1.5.1)
  • [FIXED] 4real module 3; usage with cultivators which drag to one side while sliding (1.5.1)
  • [FIXED] Headers have incorrect divider settings for different fruitTypes (1.5.1)
  • [FIXED] Köckerling Allrounder jitters above the ground (1.5.1)
  • [FIXED] AI worker stutters at the end of a line (in maize, sunflowers or canola) (1.5.1)
  • [FIXED] Animal prices in easy difficulty (won't change prizes after savegame restart) (1.5.1)
  • [FIXED] Joskin Trans-Space 8000 attacher joint ist not set correctly (1.5.1)
  • [FIXED] Valtra S attacher joint of 3-point not correctly alligned (1.5.1)
  • [FIXED] Fendt 900 series wrong radius of back wheels (1.5.1)
  • [FIXED] Ponsse Buffalo missing collision on front wheels (1.5.1)
  • [FIXED] MF Activia 7347 missing collision on front wheels (1.5.1)
  • [FIXED] Cannot cultivate manure into the ground on an already cultivated field (1.5.1)
  • [FIXED] Goods clip through back door of Joskin Trans-Space 8000 (1.5.1)
  • [FIXED] fuelUsage in MP not synchronized visually (1.5.1)
  • [FIXED] Double doors won't close completely in MP (animatedObjectsXML) (1.5.1)
  • [FIXED] Bogie bands keep turning on low loader while low loader is moving (1.5.1)
  • [FIXED] Krampe Bandit SB30/60 floats in the air after buying (1.5.1)
  • [FIXED] Camera on articulated steering machines is not alligned correctly (1.5.1)
  • [FIXED] Hint "Get in" in MP while someone already steers the machine (1.5.1)
  • [FIXED] Wheels turn in the wrong direction while driving backwards (happens only with non physical wheels) (1.5.1)
  • [FIXED] New Holland SP 400 F has adjustment problems of tireTracks in multiplayer (only as client) (1.5.1)
  • [FIXED] Using a tripple combination of attachments, the third one don't get lowered in schemaOverlay (1.5.1)
  • [FIXED] Jenz HEM error of particle effect while unloading on dedicated server (1.5.1)
  • [FIXED] Mod selection screen shows all maps, after selecting one map (1.5.1)
  • [FIXED] Amazone ED 3000-C is not fillable by trailer (1.5.1)
  • [FIXED] Great Plains 3P1006NT fillLevel indicator is not working (1.5.1)
  • [FIXED] Hayloft is not able to fill forageMixer with grass and straw (1.5.1)
  • [FIXED] Hardcoded values for AI vehicle spec controls (1.5.1)
  • [FIXED] Dedicated server doesn't show up in server browser, if language is not fitting master server (1.5.1)
  • [FIXED] Vehicles doesn't stop while pop-up is showing (1.5.1)
  • [FIXED] Loading wagon and forage harvesters have different amount statistics using the same windrow (1.5.1)
  • [FIXED] soundPlayer.lua causes call stack when game is closed by gamepad (1.5.1)
  • [FIXED] Player can walk between MF Activia 7347 S and its header (1.5.1)
  • [FIXED] Increased friction for wide tires (1.5.1)
  • [FIXED] Case IH Magnum hydraulic punches don't fit cylinders (1.5.1)
  • [FIXED] Lizard Pick Up TT left front wheel shakes (1.5.1)
  • [FIXED] Minor bugs in different translations (1.5.1)
  • [FIXED] Stoll wrapped bale handler has minor AO bugs (1.5.1)
  • [FIXED] NH T6 missing mesh (normals mirrored) in interior (1.5.1)
  • [FIXED] Missing fill diagram on the outside of Veenhuis Premium Integral II (1.5.1)
  • [FIXED] MF Activia 7347 front cylinders are too short (1.5.1)
  • [FIXED] Metaltech PP20's decals are not alligned correctly to the model (1.5.1)
  • [FIXED] Floating decal on Case Optum 270 (1.5.1)
  • [FIXED] Veenhuis Premium Integral II - Minor 3D issues (1.5.1)
  • [FIXED] Wheel nuts are missing on second axle of Tatra Phoenix (1.5.1)
  • [FIXED] Some wheels clip into fender / machine (1.5.1)
  • [FIXED] Frontlights missing on some machines in lower hardware profiles (1.5.1)
  • [TWEAKED] Terrain of Sosnovka has some edges / holes below objects (1.5.1)
  • [TWEAKED] shovelTriggers on GCV map (1.5.1)
  • [TWEAKED] Crops clip through Case IH Axial-Flow 9230 (1.5.1)
  • [TWEAKED] Ingame worker missions tweaked for 4real modules and DLC's (1.5.1)
  • [TWEAKED] AI worker turning radius with articulated steering (1.5.1)
  • [TWEAKED] Unloading of Ursus T127 (1.5.1)
  • [TWEAKED] Physical behaviour of log forks (1.5.1)
  • [TWEAKED] AI behaviour with Kuhn TF1500 (1.5.1)
  • [TWEAKED] Wheels configurations on different machines (1.5.1)
  • [TWEAKED] Cleanarea in front of feeding throughs (1.5.1)
  • [TWEAKED] Flickering of streets (1.5.1)
  • [TWEAKED] Case Magnum 380 + Kröger TAW30 wobble during filling (1.5.1)
  • [ADDED] Double wheels on some vehicles (1.5.1)
  • [ADDED] Collisions for double wheels (1.5.1)

Share this post


Link to post
Share on other sites

Also any map that uses the Animated Objects/Opening script will cause issues (and in some instances crashes) worst case scenario you may not be able to open any gates on the map.  Also the Animated Objects/Gates mod (which uses this script) is broken - so disable it until it is patched.

 

Contrary to many report Game Extension mod is not at fault, nor is it not working correctly

Share this post


Link to post
Share on other sites

So basically the game is broken for most people until they release another patch Jawdrop)

Share this post


Link to post
Share on other sites

A really smart you tube personality put a video out on how to roll back your game if you have the steam version.  HEHE.  wonder who that gent was???

 

1.5.1 totally annihilated my FPS on Churn Farm.  Would go from 60FPS down to sub 10 and back to 60.  With our with out seasons.  day or night time.  even -with new save game and no mods beyond the map.  I could reproduce this effect easy enough as it dropped almost a the same spots every time I loaded the game even after some gave saves.

 

Rolled back to 1.4.4  opened game and got a ton of render errors in log.  saved game and then went back in.  errors gone from log and FPS solid 60 again.

  • Informative 1

Share this post


Link to post
Share on other sites

I seemed to have fixed mine after Dural put up a new version of MR and I deleted the shader_cache. then I reloaded the game and run the roads again to remake the shader_cache.

shader_cache is found  in "C\Users\"name"\Documents\My Games\FarmingSimulator2017. This for PCs only no idea about Macs.

Share this post


Link to post
Share on other sites

The whole lot it makes a new folder. Means you have to run round all maps you have but it works.

As for the Animated gates I don't know what is wrong non of the maps I'm using has that script just the standard Giants script which works.

  • Informative 1

Share this post


Link to post
Share on other sites

Howdy Folks, Pardon my ignorance, but I don't understand much of what I just read. What is MR and what folders do I need to delete? I worked to long on my maps to start over, esp mountain valley. Sorry I'm not expressing problems clearly, but I looked in my save games and I have a bunch of them.

  • Like 1

Share this post


Link to post
Share on other sites

Hi @outrider MR refers to the More Realistic mod so it sounds like you dont need to worry about that also it looks like most maps are ok so try your maps first if you do have a issue then let us knowHappy)

Share this post


Link to post
Share on other sites

As @Wonkosays MR is More Realistic. The folder is where the shaders are stored for each map. What is happening to some people is they are getting a lot of stuttering when they start after patching the game engine. This make no difference if it's MR or not. They how to is to remake the shader files. If you have no problems no need to do anything. The fix will not destroy the saves:)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Terms of Use, Privacy Policy, Guidelines, We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.